# CVE-2021-4244: yikes-inc-easy-mailchimp-extender Plugin add_field_to_form.php cross site scripting

> A cross-site scripting vulnerability in the Easy Mailchimp Extender plugin allows remote attackers to inject malicious scripts via manipulated form fields.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-837v-6vgx-jqcc

## What is CVE-2021-4244?

CVE-2021-4244 is a low-severity cross-site scripting vulnerability in unspecified yikes-inc-easy-mailchimp-extender Plugin, published on 12 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic has been found in yikes-inc-easy-mailchimp-extender Plugin up to 6.8.5. This affects an unknown part of the file admin/partials/ajax/add_field_to_form.php. The manipulation of the argument field_name/merge_tag/field_type/list_id leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 6.8.6 is able to address this issue. The name of the patch is 3662c6593aa1bb4286781214891d26de2e947695. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215307.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2021-4244?

2 open source packages ship an affected version, including yikesinc/yikes-inc-easy-mailchimp-extender. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yikesinc/yikes-inc-easy-mailchimp-extender` | Packagist | All versions | 6.8.6 |
| `yikesinc/yikes-inc-easy-mailchimp-extender` | Packagist | All versions | 6.8.6 |

Products: Yikesplugins Easy Forms for Mailchimp.

## How do I fix CVE-2021-4244?

Upgrade yikesinc/yikes-inc-easy-mailchimp-extender to 6.8.6 or later.

## Is CVE-2021-4244 being exploited?

There is no known exploitation of CVE-2021-4244 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4244 and fix it if it is affected.

What it is: CVE-2021-4244 is a low-severity cross-site scripting vulnerability in unspecified yikes-inc-easy-mailchimp-extender Plugin, published on 12 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-4244 in the wild and no public exploit code.

Affected packages and fixed versions:
- yikesinc/yikes-inc-easy-mailchimp-extender (Packagist): affected all versions; fixed in 6.8.6
- yikesinc/yikes-inc-easy-mailchimp-extender (Packagist): affected all versions; fixed in 6.8.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4244/ (Markdown: https://insights.sbomify.com/CVE-2021-4244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4244
- OSV: https://osv.dev/vulnerability/CVE-2021-4244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4244/
Summaries are generated and may contain mistakes; the official description above is the record.
