{"answers":{"affected":"1 open source package ship an affected version, including xml-conduit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-4249 in the wild and no public exploit code.","fix":"Upgrade xml-conduit to 1.9.1.0 or later.","what":"CVE-2021-4249 is a medium-severity denial of service vulnerability in unspecified xml-conduit, published on 18 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-4249 and fix it if it is affected.\n\nWhat it is: CVE-2021-4249 is a medium-severity denial of service vulnerability in unspecified xml-conduit, published on 18 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-4249 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- xml-conduit (Hackage): affected from 0.5.0; fixed in 1.9.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4249/ (Markdown: https://insights.sbomify.com/CVE-2021-4249/index.md)","id":"CVE-2021-4249","markdown":"https://insights.sbomify.com/CVE-2021-4249/index.md","name":"CVE-2021-4249","record":{"aliases":["DEBIAN-CVE-2021-4249","GHSA-r5mv-3cq3-727q","HSEC-2023-0004","UBUNTU-CVE-2021-4249","openSUSE-SU-2026:11086-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Haskell XML library","requires_auth":"none","summary":"Remote attackers can cause a denial of service via an infinite loop in the DOCTYPE entity expansion handler of the xml-conduit library.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"xml-conduit","vendor":"haskell"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-404","name":"Improper Resource Shutdown or Release"}],"description":"A vulnerability was found in xml-conduit. It has been classified as problematic. Affected is an unknown function of the file xml-conduit/src/Text/XML/Stream/Parse.hs of the component DOCTYPE Entity Expansion Handler. The manipulation leads to infinite loop. It is possible to launch the attack remotely. Upgrading to version 1.9.1.0 is able to address this issue. The name of the patch is 4be1021791dcdee8b164d239433a2043dc0939ea. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216204.","ecosystems":["Hackage","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"xml-conduit DOCTYPE Entity Expansion Parse.hs infinite loop","id":"CVE-2021-4249","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"cgriego active_attr Regex boolean_typecaster.rb call denial of service","id":"CVE-2021-4250"},"packages":[{"ecosystem":"Hackage","fixed":["1.9.1.0"],"introduced":["0.5.0"],"last_affected":[],"package":"xml-conduit","purl":"pkg:hackage/xml-conduit","source":"HSEC-2023-0004"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.10.1.0-2.1"],"introduced":["0"],"last_affected":[],"package":"ghc-xml-conduit","purl":"pkg:rpm/opensuse/ghc-xml-conduit\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11086-1"}],"prev":{"headline":"kapetan dns Request.cs entropy","id":"CVE-2021-4248"},"products":["xml-conduit"],"published":"2022-12-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"open","licence":"CC0 1.0","name":"Haskell Security Response Team","prefix":"HSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["unspecified"]},"summary":"Remote attackers can cause a denial of service via an infinite loop in the DOCTYPE entity expansion handler of the xml-conduit library.","url":"https://insights.sbomify.com/CVE-2021-4249/"}