{"answers":{"affected":"2 open source packages ship an affected version, including active_attr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-4250 in the wild and no public exploit code.","fix":"Upgrade active_attr to 0.15.4 or later.","what":"CVE-2021-4250 is a low-severity denial of service vulnerability in cgriego active_attr, published on 18 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-4250 and fix it if it is affected.\n\nWhat it is: CVE-2021-4250 is a low-severity denial of service vulnerability in cgriego active_attr, published on 18 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-4250 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- active_attr (RubyGems): affected all versions; fixed in 0.15.4\n- active_attr (RubyGems): affected all versions; fixed in 0.15.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4250/ (Markdown: https://insights.sbomify.com/CVE-2021-4250/index.md)","id":"CVE-2021-4250","markdown":"https://insights.sbomify.com/CVE-2021-4250/index.md","name":"CVE-2021-4250","record":{"aliases":["GHSA-4whf-rmx5-8frv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby active_attr gem","requires_auth":"low_privilege","summary":"Attackers can cause denial of service in the active_attr Ruby gem via a regex vulnerability in the boolean typecaster.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"active_attr","vendor":"active_attr_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-404","name":"Improper Resource Shutdown or Release"}],"description":"A vulnerability classified as problematic has been found in cgriego active_attr up to 0.15.2. This affects the function call of the file lib/active_attr/typecasting/boolean_typecaster.rb of the component Regex Handler. The manipulation of the argument value leads to denial of service. The exploit has been disclosed to the public and may be used. Upgrading to version 0.15.3 is able to address this issue. The name of the patch is dab95e5843b01525444b82bd7b336ef1d79377df. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216207.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"cgriego active_attr Regex boolean_typecaster.rb call denial of service","id":"CVE-2021-4250","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":5,"next":{"headline":"as include.cdn.php getFullURL cross site scripting","id":"CVE-2021-4251"},"packages":[{"ecosystem":"RubyGems","fixed":["0.15.4"],"introduced":["0"],"last_affected":[],"package":"active_attr","purl":null,"source":"GHSA-4whf-rmx5-8frv"},{"ecosystem":"RubyGems","fixed":["0.15.4"],"introduced":["0"],"last_affected":[],"package":"active_attr","purl":"pkg:gem/active_attr","source":"GHSA-4whf-rmx5-8frv"}],"prev":{"headline":"xml-conduit DOCTYPE Entity Expansion Parse.hs infinite loop","id":"CVE-2021-4249"},"products":["active_attr"],"published":"2022-12-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["cgriego"]},"summary":"Attackers can cause denial of service in the active_attr Ruby gem via a regex vulnerability in the boolean typecaster.","url":"https://insights.sbomify.com/CVE-2021-4250/"}