# CVE-2021-4250: cgriego active_attr Regex boolean_typecaster.rb call denial of service

> Attackers can cause denial of service in the active_attr Ruby gem via a regex vulnerability in the boolean typecaster.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-4whf-rmx5-8frv

## What is CVE-2021-4250?

CVE-2021-4250 is a low-severity denial of service vulnerability in cgriego active_attr, published on 18 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability classified as problematic has been found in cgriego active_attr up to 0.15.2. This affects the function call of the file lib/active_attr/typecasting/boolean_typecaster.rb of the component Regex Handler. The manipulation of the argument value leads to denial of service. The exploit has been disclosed to the public and may be used. Upgrading to version 0.15.3 is able to address this issue. The name of the patch is dab95e5843b01525444b82bd7b336ef1d79377df. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216207.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2021-4250?

2 open source packages ship an affected version, including active_attr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `active_attr` | RubyGems | All versions | 0.15.4 |
| `active_attr` | RubyGems | All versions | 0.15.4 |

Products: Active Attr Project Active Attr.

## How do I fix CVE-2021-4250?

Upgrade active_attr to 0.15.4 or later.

## Is CVE-2021-4250 being exploited?

There is no known exploitation of CVE-2021-4250 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4250 and fix it if it is affected.

What it is: CVE-2021-4250 is a low-severity denial of service vulnerability in cgriego active_attr, published on 18 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4250 in the wild and no public exploit code.

Affected packages and fixed versions:
- active_attr (RubyGems): affected all versions; fixed in 0.15.4
- active_attr (RubyGems): affected all versions; fixed in 0.15.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4250/ (Markdown: https://insights.sbomify.com/CVE-2021-4250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4250
- OSV: https://osv.dev/vulnerability/CVE-2021-4250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4250/
Summaries are generated and may contain mistakes; the official description above is the record.
