# CVE-2021-42521: VTK NULL pointer dereference vulnerability

> A NULL pointer dereference in VTK's XML tree reader allows attackers to crash the application via crafted input.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2022
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-42521, GHSA-xfhg-9pjg-xg7g, PYSEC-2022-255, UBUNTU-CVE-2021-42521

## What is CVE-2021-42521?

CVE-2021-42521 is a high-severity vulnerability in vtk, published on 25 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

There is a NULL pointer dereference vulnerability in VTK before 9.2.5, and it lies in IO/Infovis/vtkXMLTreeReader.cxx. The vendor didn't check the return value of libxml2 API 'xmlDocGetRootElement', and try to dereference it. It is unsafe as the return value can be NULL and that NULL pointer dereference may crash the application.

Weakness: CWE-476 (NULL Pointer Dereference), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-42521?

3 open source packages ship an affected version, including vtk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vtk` | PyPI | All versions | 9.0.1 |
| `vtk` | PyPI | All versions | 9.0.1 |
| `vtk` | PyPI | All versions | 9.0.1 |

Products: Vtk Vtk.

## How do I fix CVE-2021-42521?

Upgrade vtk to 9.0.1 or later.

## Is CVE-2021-42521 being exploited?

There is no known exploitation of CVE-2021-42521 in the wild and no public exploit code.

## Other vulnerabilities in vtk

- [CVE-2025-57108](https://insights.sbomify.com/CVE-2025-57108/): Use after free in n/a (critical 9.8)
- [CVE-2025-57106](https://insights.sbomify.com/CVE-2025-57106/): Memory corruption in n/a (high 7.5)
- [CVE-2025-57107](https://insights.sbomify.com/CVE-2025-57107/): Memory corruption in n/a (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-42521 and fix it if it is affected.

What it is: CVE-2021-42521 is a high-severity vulnerability in vtk, published on 25 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-42521 in the wild and no public exploit code.

Affected packages and fixed versions:
- vtk (PyPI): affected all versions; fixed in 9.0.1
- vtk (PyPI): affected all versions; fixed in 9.0.1
- vtk (PyPI): affected all versions; fixed in 9.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-42521/ (Markdown: https://insights.sbomify.com/CVE-2021-42521/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-42521
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-42521
- OSV: https://osv.dev/vulnerability/CVE-2021-42521

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-42521/
Summaries are generated and may contain mistakes; the official description above is the record.
