# CVE-2021-4259: phpRedisAdmin login.inc.php authHttpDigest wrong operator in string comparison

> Attackers can bypass authentication in phpRedisAdmin due to a flawed string comparison in the HTTP digest login mechanism.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gmg9-6627-crjh

## What is CVE-2021-4259?

CVE-2021-4259 is a medium-severity authentication bypass vulnerability in phpRedisAdmin, published on 19 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in phpRedisAdmin up to 1.16.1. It has been classified as problematic. This affects the function authHttpDigest of the file includes/login.inc.php. The manipulation of the argument response leads to use of wrong operator in string comparison. Upgrading to version 1.16.2 is able to address this issue. The name of the patch is 31aa7661e6db6f4dffbf9a635817832a0a11c7d9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216267.

Weakness: CWE-597 (Use of Wrong Operator in String Comparison)

## Which versions are affected by CVE-2021-4259?

It affects 1 product.


Products: Phpredisadmin Project Phpredisadmin.

## How do I fix CVE-2021-4259?

No fix has been published for CVE-2021-4259 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-4259 being exploited?

There is no known exploitation of CVE-2021-4259 in the wild and no public exploit code.

## Other vulnerabilities in phpRedisAdmin

- [CVE-2020-27163](https://insights.sbomify.com/CVE-2020-27163/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2021-4268](https://insights.sbomify.com/CVE-2021-4268/): phpRedisAdmin cross-site request forgery (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4259 and fix it if it is affected.

What it is: CVE-2021-4259 is a medium-severity authentication bypass vulnerability in phpRedisAdmin, published on 19 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4259 in the wild and no public exploit code.

Affected product: phpRedisAdmin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4259/ (Markdown: https://insights.sbomify.com/CVE-2021-4259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4259
- OSV: https://osv.dev/vulnerability/CVE-2021-4259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4259/
Summaries are generated and may contain mistakes; the official description above is the record.
