# CVE-2021-4260: oils-js Web.js redirect

> An open redirect vulnerability in oils-js allows attackers to redirect users to malicious sites, requiring a patch to mitigate.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-v279-v2xm-whq9

## What is CVE-2021-4260?

CVE-2021-4260 is a medium-severity vulnerability in unspecified oils-js, published on 19 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in oils-js. It has been declared as critical. This vulnerability affects unknown code of the file core/Web.js. The manipulation leads to open redirect. The attack can be initiated remotely. The name of the patch is fad8fbae824a7d367dacb90d56cb02c5cb999d42. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216268.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2021-4260?

2 open source packages ship an affected version, including oils. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oils` | npm | All versions | 8.0.0 |
| `oils` | npm | All versions | 8.0.0 |

Products: Oils-Js Project Oils-Js.

## How do I fix CVE-2021-4260?

Upgrade oils to 8.0.0 or later.

## Is CVE-2021-4260 being exploited?

There is no known exploitation of CVE-2021-4260 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4260 and fix it if it is affected.

What it is: CVE-2021-4260 is a medium-severity vulnerability in unspecified oils-js, published on 19 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4260 in the wild and no public exploit code.

Affected packages and fixed versions:
- oils (npm): affected all versions; fixed in 8.0.0
- oils (npm): affected all versions; fixed in 8.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4260/ (Markdown: https://insights.sbomify.com/CVE-2021-4260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4260
- OSV: https://osv.dev/vulnerability/CVE-2021-4260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4260/
Summaries are generated and may contain mistakes; the official description above is the record.
