# CVE-2021-4261: pacman-canvas db-handler.php addHighscore sql injection

> Remote attackers can exploit SQL injection in the highscore handler to read or modify database contents in Pacman Canvas.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-3rm4-crwx-x46x

## What is CVE-2021-4261?

CVE-2021-4261 is a medium-severity SQL injection vulnerability in unspecified pacman-canvas, published on 19 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability classified as critical has been found in pacman-canvas up to 1.0.5. Affected is the function addHighscore of the file data/db-handler.php. The manipulation leads to sql injection. It is possible to launch the attack remotely. Upgrading to version 1.0.6 is able to address this issue. The name of the patch is 29522c90ca1cebfce6453a5af5a45281d99b0646. It is recommended to upgrade the affected component. VDB-216270 is the identifier assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2021-4261?

It affects 1 product.


Products: Pacman-Canvas Project Pacman-Canvas.

## How do I fix CVE-2021-4261?

No fix has been published for CVE-2021-4261 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-4261 being exploited?

There is no known exploitation of CVE-2021-4261 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4261 and fix it if it is affected.

What it is: CVE-2021-4261 is a medium-severity SQL injection vulnerability in unspecified pacman-canvas, published on 19 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4261 in the wild and no public exploit code.

Affected product: unspecified pacman-canvas. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4261/ (Markdown: https://insights.sbomify.com/CVE-2021-4261/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4261
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4261
- OSV: https://osv.dev/vulnerability/CVE-2021-4261

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4261/
Summaries are generated and may contain mistakes; the official description above is the record.
