{"answers":{"affected":"2 open source packages ship an affected version, including code-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-42648 in the wild and no public exploit code.","fix":"Upgrade code-server to 3.12.0 or later.","what":"CVE-2021-42648 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-42648 and fix it if it is affected.\n\nWhat it is: CVE-2021-42648 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-42648 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- code-server (npm): affected all versions; fixed in 3.12.0\n- code-server (npm): affected all versions; fixed in 3.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-42648/ (Markdown: https://insights.sbomify.com/CVE-2021-42648/index.md)","id":"CVE-2021-42648","markdown":"https://insights.sbomify.com/CVE-2021-42648/index.md","name":"CVE-2021-42648","record":{"aliases":["GHSA-2gp3-6c9p-jp7w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Code-Server","requires_auth":"none","summary":"Attackers can execute arbitrary code via crafted URLs in Code-Server, requiring an upgrade to secure the web application.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"code-server","vendor":"coder"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0, allows attackers to execute arbitrary code via crafted URL.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross site scripting in code-server","id":"CVE-2021-42648","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-42650"},"packages":[{"ecosystem":"npm","fixed":["3.12.0"],"introduced":["0"],"last_affected":[],"package":"code-server","purl":null,"source":"GHSA-2gp3-6c9p-jp7w"},{"ecosystem":"npm","fixed":["3.12.0"],"introduced":["0"],"last_affected":[],"package":"code-server","purl":"pkg:npm/code-server","source":"GHSA-2gp3-6c9p-jp7w"}],"prev":{"headline":"XML external entity in n/a","id":"CVE-2021-42646"},"products":["n/a"],"published":"2022-05-11","related":[{"cvss_score":8.2,"headline":"code-server vulnerable to Missing Origin Validation in WebSockets","id":"CVE-2023-26114","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":7.5,"headline":"Inefficient Regular Expression Complexity in cdr/code-server","id":"CVE-2021-3810","kev_date_added":null,"published":"2021-09-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via crafted URLs in Code-Server, requiring an upgrade to secure the web application.","url":"https://insights.sbomify.com/CVE-2021-42648/"}