# CVE-2021-42648: Cross site scripting in code-server

> Attackers can execute arbitrary code via crafted URLs in Code-Server, requiring an upgrade to secure the web application.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 May 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2gp3-6c9p-jp7w

## What is CVE-2021-42648?

CVE-2021-42648 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0, allows attackers to execute arbitrary code via crafted URL.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-42648?

2 open source packages ship an affected version, including code-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code-server` | npm | All versions | 3.12.0 |
| `code-server` | npm | All versions | 3.12.0 |

Products: Coder Code-Server.

## How do I fix CVE-2021-42648?

Upgrade code-server to 3.12.0 or later.

## Is CVE-2021-42648 being exploited?

There is no known exploitation of CVE-2021-42648 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-26114](https://insights.sbomify.com/CVE-2023-26114/): code-server vulnerable to Missing Origin Validation in WebSockets (high 8.2)
- [CVE-2021-3810](https://insights.sbomify.com/CVE-2021-3810/): Inefficient Regular Expression Complexity in cdr/code-server (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-42648 and fix it if it is affected.

What it is: CVE-2021-42648 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-42648 in the wild and no public exploit code.

Affected packages and fixed versions:
- code-server (npm): affected all versions; fixed in 3.12.0
- code-server (npm): affected all versions; fixed in 3.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-42648/ (Markdown: https://insights.sbomify.com/CVE-2021-42648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-42648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-42648
- OSV: https://osv.dev/vulnerability/CVE-2021-42648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-42648/
Summaries are generated and may contain mistakes; the official description above is the record.
