{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-4268 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-4268 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-4268 is a medium-severity vulnerability in unspecified phpRedisAdmin, published on 21 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-4268 and fix it if it is affected.\n\nWhat it is: CVE-2021-4268 is a medium-severity vulnerability in unspecified phpRedisAdmin, published on 21 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-4268 in the wild and no public exploit code.\n\nAffected product: unspecified phpRedisAdmin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4268/ (Markdown: https://insights.sbomify.com/CVE-2021-4268/index.md)","id":"CVE-2021-4268","markdown":"https://insights.sbomify.com/CVE-2021-4268/index.md","name":"CVE-2021-4268","record":{"aliases":["GHSA-r8r8-9qg3-423r"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Redis admin tool","requires_auth":"none","summary":"An attacker can perform unauthorized actions on behalf of a logged-in user in phpRedisAdmin via cross-site request forgery.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"phpredisadmin","vendor":"phpredisadmin_project"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"},{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"A vulnerability, which was classified as problematic, was found in phpRedisAdmin up to 1.17.3. This affects an unknown part. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 1.18.0 is able to address this issue. The name of the patch is b9039adbb264c81333328faa9575ecf8e0d2be94. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216471.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"phpRedisAdmin cross-site request forgery","id":"CVE-2021-4268","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2021"},"n_packages":0,"n_references":3,"next":{"headline":"SimpleRisk common.js checkAndSetValidation cross site scripting","id":"CVE-2021-4269"},"packages":[],"prev":{"headline":"tad_discuss cross site scripting","id":"CVE-2021-4267"},"products":["phpRedisAdmin"],"published":"2022-12-21","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2020-27163","kev_date_added":null,"published":"2020-10-16"},{"cvss_score":5,"headline":"phpRedisAdmin login.inc.php authHttpDigest wrong operator in string comparison","id":"CVE-2021-4259","kev_date_added":null,"published":"2022-12-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-14","vendors":["unspecified"]},"summary":"An attacker can perform unauthorized actions on behalf of a logged-in user in phpRedisAdmin via cross-site request forgery.","url":"https://insights.sbomify.com/CVE-2021-4268/"}