CVE-2021-42717 Denial of service in n/a

High 7.5 Published Updated

Attackers can cause denial of service by sending deeply nested JSON objects, exhausting CPU and blocking web server workers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-42717?

CVE-2021-42717 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

ModSecurity 3.x through 3.0.5 mishandles excessively nested JSON objects. Crafted JSON objects with nesting tens-of-thousands deep could result in the web server being unable to service legitimate requests. Even a moderately large (e.g., 300KB) HTTP request can occupy one of the limited NGINX worker processes for minutes and consume almost all of the available CPU on the machine. Modsecurity 2 is similarly vulnerable: the affected versions include 2.8.0 through 2.9.4.

Weakness: CWE-674

Which versions are affected by CVE-2021-42717?

2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 6 products.

PackageAffectedFixed in
modsecurity BitnamiFrom 2.0.02.9.5
modsecurity2 BitnamiFrom 2.0.02.9.5

Products include Debian Debian Linux, F5 Nginx Modsecurity Waf, Oracle Http Server, Oracle Zfs Storage Appliance Kit, Owasp Modsecurity, Trustwave Modsecurity.

How do I fix CVE-2021-42717?

Upgrade modsecurity to 2.9.5 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-42717 being exploited?

There is no known exploitation of CVE-2021-42717 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Debian Debian Linux vulnerabilities

Sources

Also known as AZL-44934, BIT-modsecurity-2021-42717, BIT-modsecurity2-2021-42717, DEBIAN-CVE-2021-42717, DLA-3031-1, DSA-5023-1 and 5 more.

Is CVE-2021-42717 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free