{"answers":{"affected":"2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 6 products.","exploited":"There is no known exploitation of CVE-2021-42717 in the wild and no public exploit code.","fix":"Upgrade modsecurity to 2.9.5 or later.","what":"CVE-2021-42717 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-42717 and fix it if it is affected.\n\nWhat it is: CVE-2021-42717 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-42717 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- modsecurity (Bitnami): affected from 2.0.0; fixed in 2.9.5\n- modsecurity2 (Bitnami): affected from 2.0.0; fixed in 2.9.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-42717/ (Markdown: https://insights.sbomify.com/CVE-2021-42717/index.md)","id":"CVE-2021-42717","markdown":"https://insights.sbomify.com/CVE-2021-42717/index.md","name":"CVE-2021-42717","record":{"aliases":["AZL-44934","BIT-modsecurity-2021-42717","BIT-modsecurity2-2021-42717","DEBIAN-CVE-2021-42717","DLA-3031-1","DSA-5023-1","GHSA-w3vf-7fpc-9fww","MGASA-2021-0576","OESA-2021-1464","OESA-2022-1954","UBUNTU-CVE-2021-42717"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Web application firewall","requires_auth":"none","summary":"Attackers can cause denial of service by sending deeply nested JSON objects, exhausting CPU and blocking web server workers.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"nginx_modsecurity_waf","vendor":"f5"},{"product":"http_server","vendor":"oracle"},{"product":"zfs_storage_appliance_kit","vendor":"oracle"},{"product":"modsecurity","vendor":"owasp"},{"product":"modsecurity","vendor":"trustwave"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"ModSecurity 3.x through 3.0.5 mishandles excessively nested JSON objects. Crafted JSON objects with nesting tens-of-thousands deep could result in the web server being unable to service legitimate requests. Even a moderately large (e.g., 300KB) HTTP request can occupy one of the limited NGINX worker processes for minutes and consume almost all of the available CPU on the machine. Modsecurity 2 is similarly vulnerable: the affected versions include 2.8.0 through 2.9.4.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2022-11-20","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2022-11-20T18:01:34Z","kind":"github_poc","ref":"https://github.com/EkamSinghWalia/Detection-and-Mitigation-script-for-CVE-2021-42717","stars":1,"title":"Detection and Mitigation script for CVE-2021-42717 -\u003e ModSecurity DoS Vulnerability in JSON Parsing "}],"tier":"poc_unverified"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2021-42717","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","oracle:http_server","oracle:zfs_storage_appliance_kit"],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Sensitive data unnecessarily returned from authenticated API","id":"CVE-2021-42718"},"packages":[{"ecosystem":"Bitnami","fixed":["2.9.5"],"introduced":["2.0.0"],"last_affected":[],"package":"modsecurity","purl":"pkg:bitnami/modsecurity","source":"BIT-modsecurity-2021-42717"},{"ecosystem":"Bitnami","fixed":["2.9.5"],"introduced":["2.0.0"],"last_affected":[],"package":"modsecurity2","purl":"pkg:bitnami/modsecurity2","source":"BIT-modsecurity2-2021-42717"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2021-42716"},"products":["n/a"],"published":"2021-12-07","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can cause denial of service by sending deeply nested JSON objects, exhausting CPU and blocking web server workers.","url":"https://insights.sbomify.com/CVE-2021-42717/"}