# CVE-2021-42717: Denial of service in n/a

> Attackers can cause denial of service by sending deeply nested JSON objects, exhausting CPU and blocking web server workers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-44934, BIT-modsecurity-2021-42717, BIT-modsecurity2-2021-42717, DEBIAN-CVE-2021-42717, DLA-3031-1, DSA-5023-1, GHSA-w3vf-7fpc-9fww, MGASA-2021-0576, OESA-2021-1464, OESA-2022-1954, UBUNTU-CVE-2021-42717

## What is CVE-2021-42717?

CVE-2021-42717 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ModSecurity 3.x through 3.0.5 mishandles excessively nested JSON objects. Crafted JSON objects with nesting tens-of-thousands deep could result in the web server being unable to service legitimate requests. Even a moderately large (e.g., 300KB) HTTP request can occupy one of the limited NGINX worker processes for minutes and consume almost all of the available CPU on the machine. Modsecurity 2 is similarly vulnerable: the affected versions include 2.8.0 through 2.9.4.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2021-42717?

2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modsecurity` | Bitnami | From 2.0.0 | 2.9.5 |
| `modsecurity2` | Bitnami | From 2.0.0 | 2.9.5 |

Products: Debian Debian Linux, F5 Nginx Modsecurity Waf, Oracle Http Server, Oracle Zfs Storage Appliance Kit, Owasp Modsecurity, Trustwave Modsecurity.

## How do I fix CVE-2021-42717?

Upgrade modsecurity to 2.9.5 or later.

## Is CVE-2021-42717 being exploited?

There is no known exploitation of CVE-2021-42717 in the wild and no public exploit code.

Public exploit code:

- Detection and Mitigation script for CVE-2021-42717 -> ModSecurity DoS Vulnerability in JSON Parsing  (github_poc): https://github.com/EkamSinghWalia/Detection-and-Mitigation-script-for-CVE-2021-42717

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-42717 and fix it if it is affected.

What it is: CVE-2021-42717 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-42717 in the wild and no public exploit code.

Affected packages and fixed versions:
- modsecurity (Bitnami): affected from 2.0.0; fixed in 2.9.5
- modsecurity2 (Bitnami): affected from 2.0.0; fixed in 2.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-42717/ (Markdown: https://insights.sbomify.com/CVE-2021-42717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-42717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-42717
- OSV: https://osv.dev/vulnerability/CVE-2021-42717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-42717/
Summaries are generated and may contain mistakes; the official description above is the record.
