# CVE-2021-42771: Directory Traversal in Babel

> Attackers can execute arbitrary code by loading malicious locale files via directory traversal in the Babel library.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2021-42771, AZL-6325, CLSA-2026-1777451880, DEBIAN-CVE-2021-42771, DLA-2790-1, DSA-5018-1, GHSA-h4m5-qpfp-3mpv, MINI-5w4v-mpvw-8hm6, PYSEC-2021-421, SUSE-SU-2021:3945-1, SUSE-SU-2021:4161-1, SUSE-SU-2022:0028-1, SUSE-SU-2022:0029-1, SUSE-SU-2022:3590-1, openSUSE-SU-2021:1553-1, openSUSE-SU-2021:3945-1, openSUSE-SU-2024:11602-1, openSUSE-SU-2024:14127-1, openSUSE-SU-2026:11986-1

## What is CVE-2021-42771?

CVE-2021-42771 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 20 Oct 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Babel.Locale in Babel before 2.9.1 allows attackers to load arbitrary locale .dat files (containing serialized Python objects) via directory traversal, leading to code execution.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-42771?

3 open source packages ship an affected version, including babel. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `babel` | PyPI | All versions | 2.9.1 |
| `babel` | PyPI | All versions | 2.9.1 |
| `babel` | PyPI | All versions | 2.9.1 |
| `python-Babel` | SUSE:Enterprise Storage 6 | All versions | 2.5.1-150000.3.3.1 |
| `python-Babel` | SUSE:HPE Helion OpenStack 8 | All versions | 2.3.4-4.3.1 |
| `python-Babel` | SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 2.5.1-150000.3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 2.5.1-150000.3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 2.5.1-150000.3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 2.5.1-150000.3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Micro 5.0 | All versions | 2.8.0-3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Micro 5.1 | All versions | 2.8.0-3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 2.8.0-3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 2.8.0-3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 2.5.3-4.8.1 |
| `python-Babel` | SUSE:Linux Enterprise Module for Python 2 15 SP2 | All versions | 2.8.0-3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Module for Python 2 15 SP3 | All versions | 2.8.0-3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 2.5.1-150000.3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 2.5.1-150000.3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Server 15-LTSS | All versions | 2.5.1-150000.3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 2.5.1-150000.3.3.1 |
| `python-Babel` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 2.5.1-150000.3.3.1 |
| `python-Babel` | SUSE:OpenStack Cloud 8 | All versions | 2.3.4-4.3.1 |
| `python-Babel` | SUSE:OpenStack Cloud 9 | All versions | 2.5.1-3.3.1 |
| `python-Babel` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 2.3.4-4.3.1 |
| `python-Babel` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 2.5.1-3.3.1 |
| `python-Babel` | openSUSE:Leap 15.2 | All versions | 2.8.0-lp152.2.3.1 |
| `python-Babel-doc` | openSUSE:Leap 15.2 | All versions | 2.8.0-lp152.2.3.1 |
| `python-Babel` | openSUSE:Leap 15.3 | All versions | 2.8.0-3.3.1 |
| `python-Babel-doc` | openSUSE:Leap 15.3 | All versions | 2.8.0-3.3.1 |
| `python-Babel` | openSUSE:Tumbleweed | All versions | 2.14.0-1.5 |
| `python-Babel` | openSUSE:Tumbleweed | All versions | 2.18.0-1.4 |
| `python-Babel` | openSUSE:Tumbleweed | All versions | 2.9.1-3.1 |

Products: Debian Debian Linux, Pocoo Babel.

## How do I fix CVE-2021-42771?

Upgrade babel to 2.9.1 or later.

## Is CVE-2021-42771 being exploited?

There is no known exploitation of CVE-2021-42771 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-42771 and fix it if it is affected.

What it is: CVE-2021-42771 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 20 Oct 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-42771 in the wild and no public exploit code.

Affected packages and fixed versions:
- babel (PyPI): affected all versions; fixed in 2.9.1
- babel (PyPI): affected all versions; fixed in 2.9.1
- babel (PyPI): affected all versions; fixed in 2.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-42771/ (Markdown: https://insights.sbomify.com/CVE-2021-42771/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-42771
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-42771
- OSV: https://osv.dev/vulnerability/CVE-2021-42771

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-42771/
Summaries are generated and may contain mistakes; the official description above is the record.
