{"answers":{"affected":"3 open source packages ship an affected version, including srp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-4286 in the wild and no public exploit code.","fix":"Upgrade srp to 1.0.17 or later.","what":"CVE-2021-4286 is a low-severity vulnerability in cocagne pysrp, published on 27 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-4286 and fix it if it is affected.\n\nWhat it is: CVE-2021-4286 is a low-severity vulnerability in cocagne pysrp, published on 27 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-4286 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- srp (PyPI): affected all versions; fixed in 1.0.17\n- srp (PyPI): affected all versions; fixed in 1.0.17\n- srp (PyPI): affected all versions; fixed in 1.0.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4286/ (Markdown: https://insights.sbomify.com/CVE-2021-4286/index.md)","id":"CVE-2021-4286","markdown":"https://insights.sbomify.com/CVE-2021-4286/index.md","name":"CVE-2021-4286","record":{"aliases":["GHSA-xmc3-9m9j-w9x4","PYSEC-2022-43014","UBUNTU-CVE-2021-4286"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python SRP library","requires_auth":"low_privilege","summary":"An attacker can exploit information exposure in the calculate_x function of the pysrp library to potentially leak sensitive data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"pysrp","vendor":"pysrp_project"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-203","name":"Observable Discrepancy"}],"description":"A vulnerability, which was classified as problematic, has been found in cocagne pysrp up to 1.0.16. This issue affects the function calculate_x of the file srp/_ctsrp.py. The manipulation leads to information exposure through discrepancy. Upgrading to version 1.0.17 is able to address this issue. The name of the patch is dba52642f5e95d3da7af1780561213ee6053195f. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216875.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"cocagne pysrp _ctsrp.py calculate_x information exposure","id":"CVE-2021-4286","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2021"},"n_packages":3,"n_references":5,"next":{"headline":"ReFirm Labs binwalk Archive Extraction extractor.py symlink","id":"CVE-2021-4287"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.17"],"introduced":["0"],"last_affected":[],"package":"srp","purl":null,"source":"GHSA-xmc3-9m9j-w9x4"},{"ecosystem":"PyPI","fixed":["1.0.17"],"introduced":["0"],"last_affected":[],"package":"srp","purl":"pkg:pypi/srp","source":"GHSA-xmc3-9m9j-w9x4"},{"ecosystem":"PyPI","fixed":["1.0.17"],"introduced":["0"],"last_affected":[],"package":"srp","purl":"pkg:pypi/srp","source":"PYSEC-2022-43014"}],"prev":{"headline":"Nagios NCPA tail.html cross site scripting","id":"CVE-2021-4285"},"products":["pysrp"],"published":"2022-12-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-11","vendors":["cocagne"]},"summary":"An attacker can exploit information exposure in the calculate_x function of the pysrp library to potentially leak sensitive data.","url":"https://insights.sbomify.com/CVE-2021-4286/"}