CVE-2021-4288 OpenMRS openmrs-module-referenceapplication userApp.gsp cross site scripting

Low 3.5 Published Updated

Remote attackers can execute arbitrary scripts in the OpenMRS reference application user interface, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2021-4288?

CVE-2021-4288 is a low-severity cross-site scripting vulnerability in openmrs-module-referenceapplication, published on 27 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in OpenMRS openmrs-module-referenceapplication up to 2.11.x. It has been rated as problematic. This issue affects some unknown processing of the file omod/src/main/webapp/pages/userApp.gsp. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.12.0 is able to address this issue. The name of the patch is 35f81901a4cb925747a9615b8706f5079d2196a1. It is recommended to upgrade the affected component. The identifier VDB-216881 was assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2021-4288?

It affects 1 product.

Products include Openmrs Reference Application.

How do I fix CVE-2021-4288?

No fix has been published for CVE-2021-4288 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-4288 being exploited?

There is no known exploitation of CVE-2021-4288 in the wild and no public exploit code.

Sources

Also known as GHSA-qc24-vqq2-gjjw.

Is CVE-2021-4288 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free