{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-4289 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-4289 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-4289 is a low-severity cross-site scripting vulnerability in openmrs-module-referenceapplication, published on 27 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-4289 and fix it if it is affected.\n\nWhat it is: CVE-2021-4289 is a low-severity cross-site scripting vulnerability in openmrs-module-referenceapplication, published on 27 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-4289 in the wild and no public exploit code.\n\nAffected product: openmrs-module-referenceapplication. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4289/ (Markdown: https://insights.sbomify.com/CVE-2021-4289/index.md)","id":"CVE-2021-4289","markdown":"https://insights.sbomify.com/CVE-2021-4289/index.md","name":"CVE-2021-4289","record":{"aliases":["GHSA-36m9-prc4-gjq2"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenMRS reference application","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via the AppId parameter in the User App Page, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"reference_application","vendor":"openmrs"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability classified as problematic was found in OpenMRS openmrs-module-referenceapplication up to 2.11.x. Affected by this vulnerability is the function post of the file omod/src/main/java/org/openmrs/module/referenceapplication/page/controller/UserAppPageController.java of the component User App Page. The manipulation of the argument AppId leads to cross site scripting. The attack can be launched remotely. Upgrading to version 2.12.0 is able to address this issue. The name of the patch is 0410c091d46eed3c132fe0fcafe5964182659f74. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216883.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"OpenMRS openmrs-module-referenceapplication User App Page UserAppPageController.java post cross site scripting","id":"CVE-2021-4289","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2021"},"n_packages":0,"n_references":6,"next":{"headline":"DHBW Fallstudie Login passport.js sql injection","id":"CVE-2021-4290"},"packages":[],"prev":{"headline":"OpenMRS openmrs-module-referenceapplication userApp.gsp cross site scripting","id":"CVE-2021-4288"},"products":["openmrs-module-referenceapplication"],"published":"2022-12-27","related":[{"cvss_score":3.5,"headline":"OpenMRS openmrs-module-referenceapplication userApp.gsp cross site scripting","id":"CVE-2021-4288","kev_date_added":null,"published":"2022-12-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-03","vendors":["OpenMRS"]},"summary":"Remote attackers can execute arbitrary scripts via the AppId parameter in the User App Page, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2021-4289/"}