CVE-2021-4292 OpenMRS Admin UI Module Manage Privilege Page privilege.gsp cross site scripting

Low 3.5 Published Updated

Remote attackers can execute arbitrary scripts via the Manage Privilege Page, potentially compromising user sessions and data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2021-4292?

CVE-2021-4292 is a low-severity cross-site scripting vulnerability in OpenMRS Admin UI Module, published on 27 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in OpenMRS Admin UI Module up to 1.4.x. It has been rated as problematic. This issue affects some unknown processing of the file omod/src/main/webapp/pages/metadata/privileges/privilege.gsp of the component Manage Privilege Page. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 4f8565425b7c74128dec9ca46dfbb9a3c1c24911. It is recommended to upgrade the affected component. The identifier VDB-216917 was assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2021-4292?

It affects 1 product.

Products include Openmrs Admin Ui Module.

How do I fix CVE-2021-4292?

No fix has been published for CVE-2021-4292 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-4292 being exploited?

There is no known exploitation of CVE-2021-4292 in the wild and no public exploit code.

Sources

Also known as GHSA-wch7-2r9h-2rj5.

Is CVE-2021-4292 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free