# CVE-2021-4292: OpenMRS Admin UI Module Manage Privilege Page privilege.gsp cross site scripting

> Remote attackers can execute arbitrary scripts via the Manage Privilege Page, potentially compromising user sessions and data.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 27 Dec 2022
- **Updated:** 19 Nov 2024
- **Also known as:** GHSA-wch7-2r9h-2rj5

## What is CVE-2021-4292?

CVE-2021-4292 is a low-severity cross-site scripting vulnerability in OpenMRS Admin UI Module, published on 27 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in OpenMRS Admin UI Module up to 1.4.x. It has been rated as problematic. This issue affects some unknown processing of the file omod/src/main/webapp/pages/metadata/privileges/privilege.gsp of the component Manage Privilege Page. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 4f8565425b7c74128dec9ca46dfbb9a3c1c24911. It is recommended to upgrade the affected component. The identifier VDB-216917 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-4292?

It affects 1 product.


Products: Openmrs Admin Ui Module.

## How do I fix CVE-2021-4292?

No fix has been published for CVE-2021-4292 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-4292 being exploited?

There is no known exploitation of CVE-2021-4292 in the wild and no public exploit code.

## Other vulnerabilities in OpenMRS Admin UI Module

- [CVE-2020-36636](https://insights.sbomify.com/CVE-2020-36636/): OpenMRS Admin UI Module Account Setup AccountPageController.java sendErrorMessage cross site scripting (low 3.5)
- [CVE-2021-4291](https://insights.sbomify.com/CVE-2021-4291/): OpenMRS Admin UI Module location.gsp cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4292 and fix it if it is affected.

What it is: CVE-2021-4292 is a low-severity cross-site scripting vulnerability in OpenMRS Admin UI Module, published on 27 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-4292 in the wild and no public exploit code.

Affected product: OpenMRS Admin UI Module. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4292/ (Markdown: https://insights.sbomify.com/CVE-2021-4292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4292
- OSV: https://osv.dev/vulnerability/CVE-2021-4292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4292/
Summaries are generated and may contain mistakes; the official description above is the record.
