{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-4293 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-4293 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-4293 is a low-severity cross-site scripting vulnerability in gnuboard youngcart5, published on 28 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-4293 and fix it if it is affected.\n\nWhat it is: CVE-2021-4293 is a low-severity cross-site scripting vulnerability in gnuboard youngcart5, published on 28 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-4293 in the wild and no public exploit code.\n\nAffected product: gnuboard youngcart5. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4293/ (Markdown: https://insights.sbomify.com/CVE-2021-4293/index.md)","id":"CVE-2021-4293","markdown":"https://insights.sbomify.com/CVE-2021-4293/index.md","name":"CVE-2021-4293","record":{"aliases":["GHSA-cr4w-9634-7vrf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"gnuboard youngcart5","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the me_link argument in the admin menu update function, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"youngcart5","vendor":"sir"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** A vulnerability classified as problematic has been found in gnuboard youngcart5 up to 5.4.5.1. Affected is an unknown function of the file adm/menu_list_update.php. The manipulation of the argument me_link leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 5.4.5.2 is able to address this issue. The name of the patch is 70daa537adfa47b87af12d85f1e698fff01785ff. It is recommended to upgrade the affected component. VDB-216954 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"gnuboard youngcart5 menu_list_update.php cross site scripting","id":"CVE-2021-4293","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2021"},"n_packages":0,"n_references":4,"next":{"headline":"OpenShift OSIN CheckClientSecret timing discrepancy","id":"CVE-2021-4294"},"packages":[],"prev":{"headline":"OpenMRS Admin UI Module Manage Privilege Page privilege.gsp cross site scripting","id":"CVE-2021-4292"},"products":["youngcart5"],"published":"2022-12-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["gnuboard"]},"summary":"Remote attackers can inject malicious scripts via the me_link argument in the admin menu update function, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2021-4293/"}