# CVE-2021-4294: OpenShift OSIN CheckClientSecret timing discrepancy

> An attacker can exploit timing discrepancies in OpenShift OSIN to potentially disclose client secret information.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-m7qp-cj9p-gj85, GO-2022-1201

## What is CVE-2021-4294?

CVE-2021-4294 is a low-severity vulnerability in Redhat Openshift Container Platform, published on 28 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in OpenShift OSIN. It has been classified as problematic. This affects the function ClientSecretMatches/CheckClientSecret. The manipulation of the argument secret leads to observable timing discrepancy. The name of the patch is 8612686d6dda34ae9ef6b5a974e4b7accb4fea29. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-216987.

Weakness: CWE-203 (Observable Discrepancy), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2021-4294?

3 open source packages ship an affected version, including github.com/openshift/osin. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openshift/osin` | Go | All versions | 1.0.2-0.20210113124101-8612686d6dda |
| `github.com/openshift/osin` | Go | All versions | 1.0.2-0.20210113124101-8612686d6dda |
| `github.com/openshift/osin` | Go | All versions | 1.0.2-0.20210113124101-8612686d6dda |

Products: Redhat Openshift Container Platform, Redhat Openshift Osin.

## How do I fix CVE-2021-4294?

Upgrade github.com/openshift/osin to 1.0.2-0.20210113124101-8612686d6dda or later.

## Is CVE-2021-4294 being exploited?

There is no known exploitation of CVE-2021-4294 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2020-27836](https://insights.sbomify.com/CVE-2020-27836/): Missing authorization in cluster-ingress-operator (critical 9.8)
- [CVE-2018-1085](https://insights.sbomify.com/CVE-2018-1085/): Misconfiguration in openshift-ansible (critical 9.0)
- [CVE-2026-54099](https://insights.sbomify.com/CVE-2026-54099/): Privilege escalation in Red Hat OpenShift Container Platform 4 (high 8.8)
- [CVE-2026-1784](https://insights.sbomify.com/CVE-2026-1784/): Ose-cluster-ingress-operator: remote code execution through haproxy configuration injection (high 8.8)
- [CVE-2021-20182](https://insights.sbomify.com/CVE-2021-20182/): Privilege escalation in openshift (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4294 and fix it if it is affected.

What it is: CVE-2021-4294 is a low-severity vulnerability in Redhat Openshift Container Platform, published on 28 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4294 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openshift/osin (Go): affected all versions; fixed in 1.0.2-0.20210113124101-8612686d6dda
- github.com/openshift/osin (Go): affected all versions; fixed in 1.0.2-0.20210113124101-8612686d6dda
- github.com/openshift/osin (Go): affected all versions; fixed in 1.0.2-0.20210113124101-8612686d6dda

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4294/ (Markdown: https://insights.sbomify.com/CVE-2021-4294/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4294
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4294
- OSV: https://osv.dev/vulnerability/CVE-2021-4294

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4294/
Summaries are generated and may contain mistakes; the official description above is the record.
