# CVE-2021-4295: XML external entity in code-validator-api

> An attacker can exploit XML external entity injection in the ONC code-validator-api to read sensitive files or cause denial of service.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-v4wv-v525-p5gq

## What is CVE-2021-4295?

CVE-2021-4295 is a medium-severity vulnerability in ONC code-validator-api, published on 29 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability classified as problematic was found in ONC code-validator-api up to 1.0.30. This vulnerability affects the function vocabularyValidationConfigurations of the file src/main/java/org/sitenv/vocabularies/configuration/CodeValidatorApiConfiguration.java of the component XML Handler. The manipulation leads to xml external entity reference. Upgrading to version 1.0.31 is able to address this issue. The name of the patch is fbd8ea121755a2d3d116b13f235bc8b61d8449af. It is recommended to upgrade the affected component. VDB-217018 is the identifier assigned to this vulnerability.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2021-4295?

It affects 1 product.


Products: Healthit Code-Validator-Api.

## How do I fix CVE-2021-4295?

No fix has been published for CVE-2021-4295 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-4295 being exploited?

There is no known exploitation of CVE-2021-4295 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4295 and fix it if it is affected.

What it is: CVE-2021-4295 is a medium-severity vulnerability in ONC code-validator-api, published on 29 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4295 in the wild and no public exploit code.

Affected product: ONC code-validator-api. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4295/ (Markdown: https://insights.sbomify.com/CVE-2021-4295/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4295
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4295
- OSV: https://osv.dev/vulnerability/CVE-2021-4295

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4295/
Summaries are generated and may contain mistakes; the official description above is the record.
