CVE-2021-4297 trampgeek jobe Restapi.php runs_post Privilege Escalation

Medium 5.5 Published Updated

Attackers can escalate privileges by manipulating the sourcefilename argument in the runs_post function of the jobe web application.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2021-4297?

CVE-2021-4297 is a medium-severity vulnerability in trampgeek jobe, published on 1 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability has been found in trampgeek jobe up to 1.6.4 and classified as problematic. This vulnerability affects the function runs_post of the file application/controllers/Restapi.php. The manipulation of the argument sourcefilename leads to an unknown weakness. Upgrading to version 1.6.5 is able to address this issue. The patch is identified as 694da5013dbecc8d30dd83e2a83e78faadf93771. It is recommended to upgrade the affected component. VDB-217174 is the identifier assigned to this vulnerability.

Weakness: CWE-276

Which versions are affected by CVE-2021-4297?

It affects 1 product.

Products include Jobe Project Jobe.

How do I fix CVE-2021-4297?

No fix has been published for CVE-2021-4297 yet. Limit exposure of the affected software until one is available.

Is CVE-2021-4297 being exploited?

There is no known exploitation of CVE-2021-4297 in the wild and no public exploit code.

Sources

Also known as GHSA-7w5v-94w3-9cq7.

Is CVE-2021-4297 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free