# CVE-2021-4297: trampgeek jobe Restapi.php runs_post Privilege Escalation

> Attackers can escalate privileges by manipulating the sourcefilename argument in the runs_post function of the jobe web application.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 1 Jan 2023
- **Updated:** 28 May 2025
- **Also known as:** GHSA-7w5v-94w3-9cq7

## What is CVE-2021-4297?

CVE-2021-4297 is a medium-severity vulnerability in trampgeek jobe, published on 1 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability has been found in trampgeek jobe up to 1.6.4 and classified as problematic. This vulnerability affects the function runs_post of the file application/controllers/Restapi.php. The manipulation of the argument sourcefilename leads to an unknown weakness. Upgrading to version 1.6.5 is able to address this issue. The patch is identified as 694da5013dbecc8d30dd83e2a83e78faadf93771. It is recommended to upgrade the affected component. VDB-217174 is the identifier assigned to this vulnerability.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2021-4297?

It affects 1 product.


Products: Jobe Project Jobe.

## How do I fix CVE-2021-4297?

No fix has been published for CVE-2021-4297 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-4297 being exploited?

There is no known exploitation of CVE-2021-4297 in the wild and no public exploit code.

## Other vulnerabilities in trampgeek jobe

- [CVE-2020-36642](https://insights.sbomify.com/CVE-2020-36642/): trampgeek jobe LanguageTask.php run_in_sandbox command injection (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4297 and fix it if it is affected.

What it is: CVE-2021-4297 is a medium-severity vulnerability in trampgeek jobe, published on 1 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4297 in the wild and no public exploit code.

Affected product: trampgeek jobe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4297/ (Markdown: https://insights.sbomify.com/CVE-2021-4297/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4297
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4297
- OSV: https://osv.dev/vulnerability/CVE-2021-4297

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4297/
Summaries are generated and may contain mistakes; the official description above is the record.
