# CVE-2021-4299: cronvel string-kit naturalSort.js naturalSort redos

> Remote attackers can cause denial of service in string-kit via inefficient regular expression complexity in naturalSort.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-pfrm-4rjw-g9q5

## What is CVE-2021-4299?

CVE-2021-4299 is a medium-severity denial of service vulnerability in cronvel string-kit, published on 2 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability classified as problematic was found in cronvel string-kit up to 0.12.7. This vulnerability affects the function naturalSort of the file lib/naturalSort.js. The manipulation leads to inefficient regular expression complexity. The attack can be initiated remotely. Upgrading to version 0.12.8 is able to address this issue. The name of the patch is 9cac4c298ee92c1695b0695951f1488884a7ca73. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217180.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-4299?

2 open source packages ship an affected version, including string-kit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `string-kit` | npm | All versions | 0.12.8 |
| `string-kit` | npm | All versions | 0.12.8 |

Products: String Kit Project String Kit.

## How do I fix CVE-2021-4299?

Upgrade string-kit to 0.12.8 or later.

## Is CVE-2021-4299 being exploited?

There is no known exploitation of CVE-2021-4299 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4299 and fix it if it is affected.

What it is: CVE-2021-4299 is a medium-severity denial of service vulnerability in cronvel string-kit, published on 2 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4299 in the wild and no public exploit code.

Affected packages and fixed versions:
- string-kit (npm): affected all versions; fixed in 0.12.8
- string-kit (npm): affected all versions; fixed in 0.12.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4299/ (Markdown: https://insights.sbomify.com/CVE-2021-4299/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4299
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4299
- OSV: https://osv.dev/vulnerability/CVE-2021-4299

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4299/
Summaries are generated and may contain mistakes; the official description above is the record.
