# CVE-2021-43008: Files or Directories Accessible to External Parties in Adminer

> An attacker can read arbitrary files on the remote server by exploiting improper access control in Adminer's remote database connection feature.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Apr 2022
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-43008, DLA-3002-1, GHSA-rxfq-3vpc-vv72, UBUNTU-CVE-2021-43008

## What is CVE-2021-43008?

CVE-2021-43008 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 5 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Access Control in Adminer versions 1.12.0 to 4.6.2 (fixed in version 4.6.3) allows an attacker to achieve Arbitrary File Read on the remote server by requesting the Adminer to connect to a remote MySQL database.

## Which versions are affected by CVE-2021-43008?

2 open source packages ship an affected version, including vrana/adminer. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vrana/adminer` | Packagist | From 1.12.0 | 4.6.3 |
| `vrana/adminer` | Packagist | From 1.12.0 | 4.6.3 |

Products: Adminer Adminer, Debian Debian Linux.

## How do I fix CVE-2021-43008?

Upgrade vrana/adminer to 4.6.3 or later.

## Is CVE-2021-43008 being exploited?

There is no known exploitation of CVE-2021-43008 in the wild and no public exploit code.

Public exploit code:

- Exploit tool for CVE-2021-43008 Adminer 1.0 up to 4.6.2 Arbitrary File Read vulnerability  (github_poc): https://github.com/p0dalirius/CVE-2021-43008-AdminerRead
- Adminer CVE-2021-43008 PoC (github_poc): https://github.com/DaturaSaturated/Adminer-CVE-2021-43008
- Environnement de démonstration pour la vulnérabilité CVE-2021-43008 d’Adminer : observer l’impact réel et tester des mesures de mitigation. (github_poc): https://github.com/Bamolitho/adminer_CVE-2021-43008

## Other vulnerabilities in Debian Debian Linux

- [CVE-2021-21311](https://insights.sbomify.com/CVE-2021-21311/): Adminer Server-Side Request Forgery (high 7.2, exploited in the wild)
- [CVE-2018-7667](https://insights.sbomify.com/CVE-2018-7667/): vrana/adminer vulnerable to SSRF by connecting to privileged ports (critical 9.8)
- [CVE-2025-43960](https://insights.sbomify.com/CVE-2025-43960/): Adminer PHP Object Injection issue leads to Denial of Service (high 8.6)
- [CVE-2026-25892](https://insights.sbomify.com/CVE-2026-25892/): Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint (high 7.5)
- [CVE-2021-29625](https://insights.sbomify.com/CVE-2021-29625/): XSS in doc_link (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43008 and fix it if it is affected.

What it is: CVE-2021-43008 is a high-severity path traversal vulnerability in Debian Debian Linux, published on 5 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43008 in the wild and no public exploit code.

Affected packages and fixed versions:
- vrana/adminer (Packagist): affected from 1.12.0; fixed in 4.6.3
- vrana/adminer (Packagist): affected from 1.12.0; fixed in 4.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43008/ (Markdown: https://insights.sbomify.com/CVE-2021-43008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43008
- OSV: https://osv.dev/vulnerability/CVE-2021-43008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43008/
Summaries are generated and may contain mistakes; the official description above is the record.
