# CVE-2021-4302: slackero phpwcms SVG File cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 4 Jan 2023
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-6629-529f-2h95

## What is CVE-2021-4302?

CVE-2021-4302 is a low-severity vulnerability in slackero phpwcms, published on 4 Jan 2023. 

### Official description

A vulnerability was found in slackero phpwcms up to 1.9.26. It has been classified as problematic. This affects an unknown part of the component SVG File Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 1.9.27 is able to address this issue. The patch is named b39db9c7ad3800f319195ff0e26a0981395b1c54. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217419.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-4302?

It affects 1 product.


Products: Phpwcms Phpwcms.

## How do I fix CVE-2021-4302?

No fix has been published for CVE-2021-4302 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-4302 being exploited?

There is no known exploitation of CVE-2021-4302 in the wild and no public exploit code.

## Other vulnerabilities in slackero phpwcms

- [CVE-2021-36424](https://insights.sbomify.com/CVE-2021-36424/): Code injection in n/a (critical 9.8)
- [CVE-2020-21784](https://insights.sbomify.com/CVE-2020-21784/): Code injection in n/a (critical 9.8)
- [CVE-2021-36426](https://insights.sbomify.com/CVE-2021-36426/): File upload in n/a (high 8.8)
- [CVE-2006-7019](https://insights.sbomify.com/CVE-2006-7019/): Code injection in n/a (high 7.5)
- [CVE-2025-5499](https://insights.sbomify.com/CVE-2025-5499/): slackero phpwcms image_resized.php getimagesize deserialization (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4302 and fix it if it is affected.

What it is: CVE-2021-4302 is a low-severity vulnerability in slackero phpwcms, published on 4 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2021-4302 in the wild and no public exploit code.

Affected product: slackero phpwcms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4302/ (Markdown: https://insights.sbomify.com/CVE-2021-4302/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4302
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4302
- OSV: https://osv.dev/vulnerability/CVE-2021-4302

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4302/
Summaries are generated and may contain mistakes; the official description above is the record.
