# CVE-2021-4303: shannah Xataface Installer install_form.js.php testftp cross site scripting


- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Jan 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-64wv-c7jw-jw2q

## What is CVE-2021-4303?

CVE-2021-4303 is a low-severity vulnerability in shannah Xataface, published on 5 Jan 2023. 

### Official description

A vulnerability, which was classified as problematic, has been found in shannah Xataface up to 2.x. Affected by this issue is the function testftp of the file install/install_form.js.php of the component Installer. The manipulation leads to cross site scripting. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 3.0.0 is able to address this issue. The patch is identified as 94143a4299e386f33bf582139cd4702571d93bde. It is recommended to upgrade the affected component. VDB-217442 is the identifier assigned to this vulnerability. NOTE: Installer is disabled by default.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-4303?

2 open source packages ship an affected version, including xataface/xataface. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xataface/xataface` | Packagist | All versions | 3.0.0 |
| `xataface/xataface` | Packagist | All versions | 3.0.0 |

Products: Xataface Project Xataface.

## How do I fix CVE-2021-4303?

Upgrade xataface/xataface to 3.0.0 or later.

## Is CVE-2021-4303 being exploited?

There is no known exploitation of CVE-2021-4303 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4303 and fix it if it is affected.

What it is: CVE-2021-4303 is a low-severity vulnerability in shannah Xataface, published on 5 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2021-4303 in the wild and no public exploit code.

Affected packages and fixed versions:
- xataface/xataface (Packagist): affected all versions; fixed in 3.0.0
- xataface/xataface (Packagist): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4303/ (Markdown: https://insights.sbomify.com/CVE-2021-4303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4303
- OSV: https://osv.dev/vulnerability/CVE-2021-4303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4303/
Summaries are generated and may contain mistakes; the official description above is the record.
