# CVE-2021-4305: Woorank robots-txt-guard patterns.js makePathPattern redos

> An attacker can cause a denial of service in the Woorank robots-txt-guard library by triggering inefficient regular expression complexity in the makePathPattern function.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2023
- **Updated:** 25 Nov 2024
- **Also known as:** GHSA-6g33-8w2q-4hxv

## What is CVE-2021-4305?

CVE-2021-4305 is a low-severity denial of service vulnerability in Woorank robots-txt-guard, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in Woorank robots-txt-guard. It has been rated as problematic. Affected by this issue is the function makePathPattern of the file lib/patterns.js. The manipulation of the argument pattern leads to inefficient regular expression complexity. The exploit has been disclosed to the public and may be used. The name of the patch is c03827cd2f9933619c23894ce7c98401ea824020. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-217448.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-4305?

2 open source packages ship an affected version, including robots-txt-guard. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `robots-txt-guard` | npm | All versions | 1.0.2 |
| `robots-txt-guard` | npm | All versions | 1.0.2 |

Products: Bridgeline Robots-Txt-Guard.

## How do I fix CVE-2021-4305?

Upgrade robots-txt-guard to 1.0.2 or later.

## Is CVE-2021-4305 being exploited?

There is no known exploitation of CVE-2021-4305 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4305 and fix it if it is affected.

What it is: CVE-2021-4305 is a low-severity denial of service vulnerability in Woorank robots-txt-guard, published on 5 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4305 in the wild and no public exploit code.

Affected packages and fixed versions:
- robots-txt-guard (npm): affected all versions; fixed in 1.0.2
- robots-txt-guard (npm): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4305/ (Markdown: https://insights.sbomify.com/CVE-2021-4305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4305
- OSV: https://osv.dev/vulnerability/CVE-2021-4305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4305/
Summaries are generated and may contain mistakes; the official description above is the record.
