CVE-2021-4306 cronvel terminal-kit redos

Low 3.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2021-4306?

CVE-2021-4306 is a low-severity vulnerability in cronvel terminal-kit, published on 7 Jan 2023.

Official description

A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is a2e446cc3927b559d0281683feb9b821e83b758c. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217620.

Weakness: CWE-1333

Which versions are affected by CVE-2021-4306?

2 open source packages ship an affected version, including terminal-kit. It affects 1 product.

PackageAffectedFixed in
terminal-kit npmAll versions2.1.8
terminal-kit npmAll versions2.1.8

Products include Terminal-Kit Project Terminal-Kit.

How do I fix CVE-2021-4306?

Upgrade terminal-kit to 2.1.8 or later.

Is CVE-2021-4306 being exploited?

There is no known exploitation of CVE-2021-4306 in the wild and no public exploit code.

Sources

Also known as GHSA-wxgh-8gmr-3qh3.

Is CVE-2021-4306 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free