# CVE-2021-4306: cronvel terminal-kit redos


- **Severity:** Low 3.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Jan 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-wxgh-8gmr-3qh3

## What is CVE-2021-4306?

CVE-2021-4306 is a low-severity vulnerability in cronvel terminal-kit, published on 7 Jan 2023. 

### Official description

A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 is able to address this issue. The name of the patch is a2e446cc3927b559d0281683feb9b821e83b758c. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217620.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-4306?

2 open source packages ship an affected version, including terminal-kit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `terminal-kit` | npm | All versions | 2.1.8 |
| `terminal-kit` | npm | All versions | 2.1.8 |

Products: Terminal-Kit Project Terminal-Kit.

## How do I fix CVE-2021-4306?

Upgrade terminal-kit to 2.1.8 or later.

## Is CVE-2021-4306 being exploited?

There is no known exploitation of CVE-2021-4306 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4306 and fix it if it is affected.

What it is: CVE-2021-4306 is a low-severity vulnerability in cronvel terminal-kit, published on 7 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2021-4306 in the wild and no public exploit code.

Affected packages and fixed versions:
- terminal-kit (npm): affected all versions; fixed in 2.1.8
- terminal-kit (npm): affected all versions; fixed in 2.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4306/ (Markdown: https://insights.sbomify.com/CVE-2021-4306/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4306
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4306
- OSV: https://osv.dev/vulnerability/CVE-2021-4306

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4306/
Summaries are generated and may contain mistakes; the official description above is the record.
