# CVE-2021-4307: Yomguithereal Baobab prototype pollution


- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Jan 2023
- **Updated:** 25 Nov 2024
- **Also known as:** GHSA-wvr2-q86m-6whp

## What is CVE-2021-4307?

CVE-2021-4307 is a medium-severity vulnerability in Yomguithereal Baobab, published on 7 Jan 2023. 

### Official description

A vulnerability was found in Yomguithereal Baobab up to 2.6.0. It has been declared as critical. Affected by this vulnerability is an unknown functionality. The manipulation leads to improperly controlled modification of object prototype attributes ('prototype pollution'). The attack can be launched remotely. Upgrading to version 2.6.1 is able to address this issue. The patch is named c56639532a923d9a1600fb863ec7551b188b5d19. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217627.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2021-4307?

2 open source packages ship an affected version, including baobab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `baobab` | npm | All versions | 2.6.1 |
| `baobab` | npm | All versions | 2.6.1 |

Products: Baobab Project Baobab.

## How do I fix CVE-2021-4307?

Upgrade baobab to 2.6.1 or later.

## Is CVE-2021-4307 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4307 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4307 and fix it if it is affected.

What it is: CVE-2021-4307 is a medium-severity vulnerability in Yomguithereal Baobab, published on 7 Jan 2023. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4307 exists.

Affected packages and fixed versions:
- baobab (npm): affected all versions; fixed in 2.6.1
- baobab (npm): affected all versions; fixed in 2.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4307/ (Markdown: https://insights.sbomify.com/CVE-2021-4307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4307
- OSV: https://osv.dev/vulnerability/CVE-2021-4307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4307/
Summaries are generated and may contain mistakes; the official description above is the record.
