# CVE-2021-43091: SQL Injection in Yeswiki

> An attacker can execute arbitrary SQL commands via the email parameter in the registration form of Yeswiki doryphore.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xgx2-332h-9x6q

## What is CVE-2021-43091?

CVE-2021-43091 is a high-severity SQL injection vulnerability in n/a, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An SQL Injection vlnerability exits in Yeswiki doryphore 20211012 via the email parameter in the registration form.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2021-43091?

2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.1.0 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.1.0 |

Products: Yeswiki Yeswiki.

## How do I fix CVE-2021-43091?

Upgrade yeswiki/yeswiki to 4.1.0 or later.

## Is CVE-2021-43091 being exploited?

There is no known exploitation of CVE-2021-43091 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-46348](https://insights.sbomify.com/CVE-2025-46348/): YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download (critical 10.0)
- [CVE-2024-51478](https://insights.sbomify.com/CVE-2024-51478/): Use of a Broken or Risky Cryptographic Algorithm in YesWiki (critical 9.9)
- [CVE-2018-1000641](https://insights.sbomify.com/CVE-2018-1000641/): Deserialization in n/a (critical 9.8)
- [CVE-2025-31131](https://insights.sbomify.com/CVE-2025-31131/): Path Traversal allowing arbitrary read of files in Yeswiki (high 8.6)
- [CVE-2025-46349](https://insights.sbomify.com/CVE-2025-46349/): YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43091 and fix it if it is affected.

What it is: CVE-2021-43091 is a high-severity SQL injection vulnerability in n/a, published on 25 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43091 in the wild and no public exploit code.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.1.0
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43091/ (Markdown: https://insights.sbomify.com/CVE-2021-43091/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43091
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43091
- OSV: https://osv.dev/vulnerability/CVE-2021-43091

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43091/
Summaries are generated and may contain mistakes; the official description above is the record.
