CVE-2021-4315 NYUCCL psiTurk experiment.py special elements used in a template engine

Medium 5.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2021-4315?

CVE-2021-4315 is a medium-severity vulnerability in NYUCCL psiTurk, published on 28 Jan 2023.

Official description

A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.

Weakness: CWE-94, CWE-1336

Which versions are affected by CVE-2021-4315?

3 open source packages ship an affected version, including psiturk and psiTurk. It affects 1 product.

PackageAffectedFixed in
psiturk PyPIAll versions3.2.1
psiturk PyPIAll versions3.2.1
psiTurk PyPIAll versions3.2.1

Products include Psiturk Psiturk.

How do I fix CVE-2021-4315?

Upgrade psiturk to 3.2.1 or later.

Is CVE-2021-4315 being exploited?

There is no known exploitation of CVE-2021-4315 in the wild and no public exploit code.

Sources

Also known as GHSA-9mq4-9556-6qxq, PYSEC-2023-43.

Is CVE-2021-4315 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free