# CVE-2021-4315: NYUCCL psiTurk experiment.py special elements used in a template engine


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Jan 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-9mq4-9556-6qxq, PYSEC-2023-43

## What is CVE-2021-4315?

CVE-2021-4315 is a medium-severity vulnerability in NYUCCL psiTurk, published on 28 Jan 2023. 

### Official description

A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2021-4315?

3 open source packages ship an affected version, including psiturk and psiTurk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `psiturk` | PyPI | All versions | 3.2.1 |
| `psiturk` | PyPI | All versions | 3.2.1 |
| `psiTurk` | PyPI | All versions | 3.2.1 |

Products: Psiturk Psiturk.

## How do I fix CVE-2021-4315?

Upgrade psiturk to 3.2.1 or later.

## Is CVE-2021-4315 being exploited?

There is no known exploitation of CVE-2021-4315 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4315 and fix it if it is affected.

What it is: CVE-2021-4315 is a medium-severity vulnerability in NYUCCL psiTurk, published on 28 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2021-4315 in the wild and no public exploit code.

Affected packages and fixed versions:
- psiturk (PyPI): affected all versions; fixed in 3.2.1
- psiturk (PyPI): affected all versions; fixed in 3.2.1
- psiTurk (PyPI): affected all versions; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4315/ (Markdown: https://insights.sbomify.com/CVE-2021-4315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4315
- OSV: https://osv.dev/vulnerability/CVE-2021-4315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4315/
Summaries are generated and may contain mistakes; the official description above is the record.
