# CVE-2021-43174: gzip transfer encoding caused out-of-memory crash

> A malicious RRDP repository can cause Routinator to crash via memory exhaustion using gzip-compressed XML whitespace.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2021
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-43174, GHSA-6mv9-qcx2-3hh3

## What is CVE-2021-43174?

CVE-2021-43174 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 9 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLnet Labs Routinator versions 0.9.0 up to and including 0.10.1, support the gzip transfer encoding when querying RRDP repositories. This encoding can be used by an RRDP repository to cause an out-of-memory crash in these versions of Routinator. RRDP uses XML which allows arbitrary amounts of white space in the encoded data. The gzip scheme compresses such white space extremely well, leading to very small compressed files that become huge when being decompressed for further processing, big enough that Routinator runs out of memory when parsing input data waiting for the next XML element.

Weakness: CWE-787 (Out-of-bounds Write), CWE-1325 (Improperly Controlled Sequential Memory Allocation)

## Which versions are affected by CVE-2021-43174?

2 open source packages ship an affected version, including routinator. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `routinator` | crates.io | From 0.9.0 | 0.10.2 |
| `routinator` | crates.io | From 0.9.0 | 0.10.2 |

Products: Debian Debian Linux, Nlnetlabs Routinator.

## How do I fix CVE-2021-43174?

Upgrade routinator to 0.10.2 or later.

## Is CVE-2021-43174 being exploited?

There is no known exploitation of CVE-2021-43174 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43174 and fix it if it is affected.

What it is: CVE-2021-43174 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 9 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43174 in the wild and no public exploit code.

Affected packages and fixed versions:
- routinator (crates.io): affected from 0.9.0; fixed in 0.10.2
- routinator (crates.io): affected from 0.9.0; fixed in 0.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43174/ (Markdown: https://insights.sbomify.com/CVE-2021-43174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43174
- OSV: https://osv.dev/vulnerability/CVE-2021-43174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43174/
Summaries are generated and may contain mistakes; the official description above is the record.
