# CVE-2021-43177: Improper one time password handling in devise-two-factor

> Attackers can reuse a One-Time-Password for one trailing interval, bypassing two-factor authentication in the devise-two-factor Ruby library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2022
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-43177, GHSA-jm35-h8q2-73mp, UBUNTU-CVE-2021-43177

## What is CVE-2021-43177?

CVE-2021-43177 is a medium-severity vulnerability in Tinfoil devise-two-factor, published on 11 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

As a result of an incomplete fix for CVE-2015-7225, in versions of devise-two-factor prior to 4.0.2 it is possible to reuse a One-Time-Password (OTP) for one (and only one) immediately trailing interval. CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N)

Weakness: CWE-254

## Which versions are affected by CVE-2021-43177?

2 open source packages ship an affected version, including devise-two-factor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devise-two-factor` | RubyGems | All versions | 4.0.2 |
| `devise-two-factor` | RubyGems | All versions | 4.0.2 |

Products: Tinfoilsecurity Devise-Two-Factor.

## How do I fix CVE-2021-43177?

Upgrade devise-two-factor to 4.0.2 or later.

## Is CVE-2021-43177 being exploited?

There is no known exploitation of CVE-2021-43177 in the wild and no public exploit code.

## Other vulnerabilities in Tinfoil devise-two-factor

- [CVE-2024-8796](https://insights.sbomify.com/CVE-2024-8796/): Insufficient Default OTP Shared Secret Length (medium 6.0)
- [CVE-2015-7225](https://insights.sbomify.com/CVE-2015-7225/): Tinfoil Devise-two-factor does not "burn" a successfully validated one-time password (OTP) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43177 and fix it if it is affected.

What it is: CVE-2021-43177 is a medium-severity vulnerability in Tinfoil devise-two-factor, published on 11 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43177 in the wild and no public exploit code.

Affected packages and fixed versions:
- devise-two-factor (RubyGems): affected all versions; fixed in 4.0.2
- devise-two-factor (RubyGems): affected all versions; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43177/ (Markdown: https://insights.sbomify.com/CVE-2021-43177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43177
- OSV: https://osv.dev/vulnerability/CVE-2021-43177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43177/
Summaries are generated and may contain mistakes; the official description above is the record.
