CVE-2021-4329 json-logic-js logic.js command injection

Medium 5.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2021-4329?

CVE-2021-4329 is a medium-severity vulnerability in json-logic-js, published on 5 Mar 2023.

Official description

A vulnerability, which was classified as critical, has been found in json-logic-js 2.0.0. Affected by this issue is some unknown functionality of the file logic.js. The manipulation leads to command injection. Upgrading to version 2.0.1 is able to address this issue. The patch is identified as c1dd82f5b15d8a553bb7a0cfa841ab8a11a9c227. It is recommended to upgrade the affected component. VDB-222266 is the identifier assigned to this vulnerability.

Weakness: CWE-77

Which versions are affected by CVE-2021-4329?

2 open source packages ship an affected version, including json-logic-js. It affects 1 product.

PackageAffectedFixed in
json-logic-js npmAll versions2.0.1
json-logic-js npmAll versions2.0.1

Products include Json-Logic-Js Project Json-Logic-Js.

How do I fix CVE-2021-4329?

Upgrade json-logic-js to 2.0.1 or later.

Is CVE-2021-4329 being exploited?

There is no known exploitation of CVE-2021-4329 in the wild and no public exploit code.

Sources

Also known as GHSA-67j4-2mh6-8627.

Is CVE-2021-4329 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free