# CVE-2021-43297: Dubbo Hessian cause RCE when parse error

> A deserialization flaw in Apache Dubbo's Hessian protocol allows remote attackers to execute arbitrary code via crafted serialized objects.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vp5x-3v8r-qprw

## What is CVE-2021-43297?

CVE-2021-43297 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 10 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A deserialization vulnerability existed in dubbo hessian-lite 3.2.11 and its earlier versions, which could lead to malicious code execution. Most Dubbo users use Hessian2 as the default serialization/deserialization protocol, during Hessian catch unexpected exceptions, Hessian will log out some imformation for users, which may cause remote command execution. This issue affects Apache Dubbo Apache Dubbo 2.6.x versions prior to 2.6.12; Apache Dubbo 2.7.x versions prior to 2.7.15; Apache Dubbo 3.0.x versions prior to 3.0.5.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-43297?

6 open source packages ship an affected version, including org.apache.dubbo:dubbo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dubbo:dubbo` | Maven | From 2.6.0 | 2.6.12 |
| `org.apache.dubbo:dubbo` | Maven | From 2.6.0 | 2.6.12 |
| `org.apache.dubbo:dubbo` | Maven | From 2.7.0 | 2.7.15 |
| `org.apache.dubbo:dubbo` | Maven | From 2.7.0 | 2.7.15 |
| `org.apache.dubbo:dubbo` | Maven | From 3.0.0 | 3.0.5 |
| `org.apache.dubbo:dubbo` | Maven | From 3.0.0 | 3.0.5 |

Products: Apache Dubbo.

## How do I fix CVE-2021-43297?

Upgrade org.apache.dubbo:dubbo to a fixed version for your release line: 2.6.12, 2.7.15 or 3.0.5.

## Is CVE-2021-43297 being exploited?

There is no known exploitation of CVE-2021-43297 in the wild and no public exploit code.

Public exploit code:

- Apache Dubbo Hessian2 CVE-2021-43297 demo (github_poc): https://github.com/longofo/Apache-Dubbo-Hessian2-CVE-2021-43297
- CVE-2021-43297 POC，Apache Dubbo<= 2.7.13时可以实现RCE (github_poc): https://github.com/bitterzzZZ/CVE-2021-43297-POC

## Other vulnerabilities in Apache Dubbo

- [CVE-2023-29234](https://insights.sbomify.com/CVE-2023-29234/): Bypass serialize checks in Apache Dubbo (critical 9.8)
- [CVE-2023-46279](https://insights.sbomify.com/CVE-2023-46279/): Apache Dubbo: Bypass deny serialize list check in Apache Dubbo (critical 9.8)
- [CVE-2021-32824](https://insights.sbomify.com/CVE-2021-32824/): Regular expression Denial of Service in MooTools (critical 9.8)
- [CVE-2022-39198](https://insights.sbomify.com/CVE-2022-39198/): Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass (critical 9.8)
- [CVE-2021-36161](https://insights.sbomify.com/CVE-2021-36161/): Unprotected input value toString cause RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43297 and fix it if it is affected.

What it is: CVE-2021-43297 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 10 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43297 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dubbo:dubbo (Maven): affected from 2.6.0; fixed in 2.6.12
- org.apache.dubbo:dubbo (Maven): affected from 2.6.0; fixed in 2.6.12
- org.apache.dubbo:dubbo (Maven): affected from 2.7.0; fixed in 2.7.15
- org.apache.dubbo:dubbo (Maven): affected from 2.7.0; fixed in 2.7.15
- org.apache.dubbo:dubbo (Maven): affected from 3.0.0; fixed in 3.0.5
- org.apache.dubbo:dubbo (Maven): affected from 3.0.0; fixed in 3.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43297/ (Markdown: https://insights.sbomify.com/CVE-2021-43297/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43297
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43297
- OSV: https://osv.dev/vulnerability/CVE-2021-43297

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43297/
Summaries are generated and may contain mistakes; the official description above is the record.
