{"answers":{"affected":"2 open source packages ship an affected version, including uri-template-lite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-43309 in the wild and no public exploit code.","fix":"Upgrade uri-template-lite to 22.9.0 or later.","what":"CVE-2021-43309 is a medium-severity denial of service vulnerability in uri-template-lite, published on 24 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-43309 and fix it if it is affected.\n\nWhat it is: CVE-2021-43309 is a medium-severity denial of service vulnerability in uri-template-lite, published on 24 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-43309 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uri-template-lite (npm): affected all versions; fixed in 22.9.0\n- uri-template-lite (npm): affected all versions; fixed in 22.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43309/ (Markdown: https://insights.sbomify.com/CVE-2021-43309/index.md)","id":"CVE-2021-43309","markdown":"https://insights.sbomify.com/CVE-2021-43309/index.md","name":"CVE-2021-43309","record":{"aliases":["GHSA-chw2-6c7r-37p7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm URI template library","requires_auth":"none","summary":"An attacker can cause a denial of service by supplying malicious input to the URI.expand function in the uri-template-lite library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"JFROG","cpe":[{"product":"uri-template-lite","vendor":"litejs"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the uri-template-lite npm package, when an attacker is able to supply arbitrary input to the \"URI.expand\" method","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ReDoS in uri-template-lite URI.expand function","id":"CVE-2021-43309","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Auth bypass in keylime","id":"CVE-2021-43310"},"packages":[{"ecosystem":"npm","fixed":["22.9.0"],"introduced":["0"],"last_affected":[],"package":"uri-template-lite","purl":null,"source":"GHSA-chw2-6c7r-37p7"},{"ecosystem":"npm","fixed":["22.9.0"],"introduced":["0"],"last_affected":[],"package":"uri-template-lite","purl":"pkg:npm/uri-template-lite","source":"GHSA-chw2-6c7r-37p7"}],"prev":{"headline":"Exponential ReDoS in markdown-link-extractor","id":"CVE-2021-43308"},"products":["uri-template-lite"],"published":"2022-08-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["uri-template-lite"]},"summary":"An attacker can cause a denial of service by supplying malicious input to the URI.expand function in the uri-template-lite library.","url":"https://insights.sbomify.com/CVE-2021-43309/"}