# CVE-2021-43309: ReDoS in uri-template-lite URI.expand function

> An attacker can cause a denial of service by supplying malicious input to the URI.expand function in the uri-template-lite library.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-chw2-6c7r-37p7

## What is CVE-2021-43309?

CVE-2021-43309 is a medium-severity denial of service vulnerability in uri-template-lite, published on 24 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the uri-template-lite npm package, when an attacker is able to supply arbitrary input to the "URI.expand" method

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-43309?

2 open source packages ship an affected version, including uri-template-lite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uri-template-lite` | npm | All versions | 22.9.0 |
| `uri-template-lite` | npm | All versions | 22.9.0 |

Products: Litejs Uri-Template-Lite.

## How do I fix CVE-2021-43309?

Upgrade uri-template-lite to 22.9.0 or later.

## Is CVE-2021-43309 being exploited?

There is no known exploitation of CVE-2021-43309 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43309 and fix it if it is affected.

What it is: CVE-2021-43309 is a medium-severity denial of service vulnerability in uri-template-lite, published on 24 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43309 in the wild and no public exploit code.

Affected packages and fixed versions:
- uri-template-lite (npm): affected all versions; fixed in 22.9.0
- uri-template-lite (npm): affected all versions; fixed in 22.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43309/ (Markdown: https://insights.sbomify.com/CVE-2021-43309/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43309
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43309
- OSV: https://osv.dev/vulnerability/CVE-2021-43309

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43309/
Summaries are generated and may contain mistakes; the official description above is the record.
