CVE-2021-43415 Improper Authentication in HashiCorp Nomad
Authenticated users can bypass image path restrictions in the QEMU task driver, potentially executing unauthorized workloads.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-43415?
CVE-2021-43415 is a high-severity vulnerability in n/a, published on 3 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task driver enabled, allowed authenticated users with job submission capabilities to bypass the configured allowed image paths. Fixed in 1.0.14, 1.1.8, and 1.2.1.
Which versions are affected by CVE-2021-43415?
7 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/nomad Go | All versions | 1.0.14, 1.1.8, 1.2.1 |
github.com/hashicorp/nomad Go | All versions | 1.0.14 |
github.com/hashicorp/nomad Go | All versions | 1.0.14 |
github.com/hashicorp/nomad Go | From 1.1.0 | 1.1.8 |
github.com/hashicorp/nomad Go | From 1.1.0 | 1.1.8 |
github.com/hashicorp/nomad Go | From 1.2.0 | 1.2.1 |
1 more packages
github.com/hashicorp/nomad Go | From 1.2.0 | 1.2.1 |
Products include Hashicorp Nomad.
How do I fix CVE-2021-43415?
Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.0.14, 1.1.8 or 1.2.1.
Is CVE-2021-43415 being exploited?
There is no known exploitation of CVE-2021-43415 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2023-1782 Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation
- CVE-2022-30324 Privilege escalation in Hashicorp Nomad
- CVE-2020-7956 Improper Certificate Validation in HashiCorp Nomad
- CVE-2019-12618 Hashicorp Nomad Access Control Issues
- CVE-2020-27195 Use After Free in HashiCorp Nomad
Sources
Also known as GHSA-2jhh-5xm2-j4gf, GO-2022-0573, UBUNTU-CVE-2021-43415.