# CVE-2021-43415: Improper Authentication in HashiCorp Nomad

> Authenticated users can bypass image path restrictions in the QEMU task driver, potentially executing unauthorized workloads.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2jhh-5xm2-j4gf, GO-2022-0573, UBUNTU-CVE-2021-43415

## What is CVE-2021-43415?

CVE-2021-43415 is a high-severity vulnerability in n/a, published on 3 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task driver enabled, allowed authenticated users with job submission capabilities to bypass the configured allowed image paths. Fixed in 1.0.14, 1.1.8, and 1.2.1.

## Which versions are affected by CVE-2021-43415?

7 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/nomad` | Go | All versions | 1.0.14, 1.1.8, 1.2.1 |
| `github.com/hashicorp/nomad` | Go | All versions | 1.0.14 |
| `github.com/hashicorp/nomad` | Go | All versions | 1.0.14 |
| `github.com/hashicorp/nomad` | Go | From 1.1.0 | 1.1.8 |
| `github.com/hashicorp/nomad` | Go | From 1.1.0 | 1.1.8 |
| `github.com/hashicorp/nomad` | Go | From 1.2.0 | 1.2.1 |
| `github.com/hashicorp/nomad` | Go | From 1.2.0 | 1.2.1 |

Products: Hashicorp Nomad.

## How do I fix CVE-2021-43415?

Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.0.14, 1.1.8 or 1.2.1.

## Is CVE-2021-43415 being exploited?

There is no known exploitation of CVE-2021-43415 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-1782](https://insights.sbomify.com/CVE-2023-1782/): Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation (critical 10.0)
- [CVE-2022-30324](https://insights.sbomify.com/CVE-2022-30324/): Privilege escalation in Hashicorp Nomad (critical 9.8)
- [CVE-2020-7956](https://insights.sbomify.com/CVE-2020-7956/): Improper Certificate Validation in HashiCorp Nomad (critical 9.8)
- [CVE-2019-12618](https://insights.sbomify.com/CVE-2019-12618/): Hashicorp Nomad Access Control Issues (critical 9.8)
- [CVE-2020-27195](https://insights.sbomify.com/CVE-2020-27195/): Use After Free in HashiCorp Nomad (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43415 and fix it if it is affected.

What it is: CVE-2021-43415 is a high-severity vulnerability in n/a, published on 3 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43415 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 1.0.14, 1.1.8, 1.2.1
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 1.0.14
- github.com/hashicorp/nomad (Go): affected all versions; fixed in 1.0.14
- github.com/hashicorp/nomad (Go): affected from 1.1.0; fixed in 1.1.8
- github.com/hashicorp/nomad (Go): affected from 1.1.0; fixed in 1.1.8
- github.com/hashicorp/nomad (Go): affected from 1.2.0; fixed in 1.2.1
- github.com/hashicorp/nomad (Go): affected from 1.2.0; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43415/ (Markdown: https://insights.sbomify.com/CVE-2021-43415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43415
- OSV: https://osv.dev/vulnerability/CVE-2021-43415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43415/
Summaries are generated and may contain mistakes; the official description above is the record.
