# CVE-2021-43557: Path traversal in request_uri variable

> Attackers can bypass URI block lists in Apache APISIX by using unnormalized request URIs, potentially accessing restricted internal endpoints.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-apisix-2021-43557, GHSA-9wxc-375c-cvq2

## What is CVE-2021-43557?

CVE-2021-43557 is a high-severity path traversal vulnerability in Apache APISIX, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The uri-block plugin in Apache APISIX before 2.10.2 uses $request_uri without verification. The $request_uri is the full original request URI without normalization. This makes it possible to construct a URI to bypass the block list on some occasions. For instance, when the block list contains "^/internal/", a URI like `//internal/` can be used to bypass it. Some other plugins also have the same issue. And it may affect the developer's custom plugin.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2021-43557?

1 open source package ship an affected version, including apisix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | All versions | 2.10.2 |

Products: Apache Apisix.

## How do I fix CVE-2021-43557?

Upgrade apisix to 2.10.2 or later.

## Is CVE-2021-43557 being exploited?

There is no known exploitation of CVE-2021-43557 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2021-43557 (github_poc): https://github.com/xvnpw/k8s-CVE-2021-43557-poc

## Other vulnerabilities in Apache APISIX

- [CVE-2022-24112](https://insights.sbomify.com/CVE-2022-24112/): Apache APISIX Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2022-25757](https://insights.sbomify.com/CVE-2022-25757/): Apache APISIX: the body_schema check in request-validation plugin can be bypassed (critical 9.8)
- [CVE-2026-31908](https://insights.sbomify.com/CVE-2026-31908/): Apache APISIX: forward auth plugin allows header injection (critical 9.1)
- [CVE-2026-75005](https://insights.sbomify.com/CVE-2026-75005/): Apache APISIX: Unauthenticated CPU-exhaustion DoS (high 8.7)
- [CVE-2025-27446](https://insights.sbomify.com/CVE-2025-27446/): Privilege escalation in Apache APISIX Java Plugin Runner (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43557 and fix it if it is affected.

What it is: CVE-2021-43557 is a high-severity path traversal vulnerability in Apache APISIX, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43557 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected all versions; fixed in 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43557/ (Markdown: https://insights.sbomify.com/CVE-2021-43557/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43557
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43557
- OSV: https://osv.dev/vulnerability/CVE-2021-43557

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43557/
Summaries are generated and may contain mistakes; the official description above is the record.
