CVE-2021-43558 Cross-site Scripting in moodle
Reflected XSS in Moodle's site administrator tool allows attackers to execute scripts via unsanitized URL parameters.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-43558?
CVE-2021-43558 is a medium-severity cross-site scripting vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.
Weakness: CWE-79
Which versions are affected by CVE-2021-43558?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10.0 | 3.10.8 |
moodle/moodle Packagist | From 3.10.0 | 3.10.8 |
moodle/moodle Packagist | From 3.11.0 | 3.11.4 |
moodle/moodle Packagist | From 3.11.0 | 3.11.4 |
moodle/moodle Packagist | From 3.9.0 | 3.9.11 |
moodle/moodle Packagist | From 3.9.0 | 3.9.11 |
1 more packages
moodle Bitnami | All versions | 3.8.9, 3.9.11, 3.10.8, 3.11.4 |
Products include Fedoraproject Extra Packages for Enterprise Linux, Fedoraproject Fedora, Moodle Moodle.
How do I fix CVE-2021-43558?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.8, 3.11.4 or 3.9.11.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-43558 being exploited?
There is no known exploitation of CVE-2021-43558 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Extra Packages for Enterprise Linux
- CVE-2023-34152 Command injection in ImageMagick
- CVE-2022-4170 Code injection in rxvt-unicode
- CVE-2022-40315 Moodle Minor SQL injection risk in admin user browsing
- CVE-2022-45152 Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library
- CVE-2022-24882 Server side NTLM does not properly check parameters in FreeRDP
All Fedoraproject Extra Packages for Enterprise Linux vulnerabilities
Sources
Also known as BIT-moodle-2021-43558, GHSA-wpfp-q843-v772, UBUNTU-CVE-2021-43558.