{"answers":{"affected":"7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-43558 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.10.8, 3.11.4 or 3.9.11.","what":"CVE-2021-43558 is a medium-severity cross-site scripting vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-43558 and fix it if it is affected.\n\nWhat it is: CVE-2021-43558 is a medium-severity cross-site scripting vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-43558 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.10.0; fixed in 3.10.8\n- moodle/moodle (Packagist): affected from 3.10.0; fixed in 3.10.8\n- moodle/moodle (Packagist): affected from 3.11.0; fixed in 3.11.4\n- moodle/moodle (Packagist): affected from 3.11.0; fixed in 3.11.4\n- moodle/moodle (Packagist): affected from 3.9.0; fixed in 3.9.11\n- moodle/moodle (Packagist): affected from 3.9.0; fixed in 3.9.11\n- moodle (Bitnami): affected all versions; fixed in 3.8.9, 3.9.11, 3.10.8, 3.11.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43558/ (Markdown: https://insights.sbomify.com/CVE-2021-43558/index.md)","id":"CVE-2021-43558","markdown":"https://insights.sbomify.com/CVE-2021-43558/index.md","name":"CVE-2021-43558","record":{"aliases":["BIT-moodle-2021-43558","GHSA-wpfp-q843-v772","UBUNTU-CVE-2021-43558"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Reflected XSS in Moodle's site administrator tool allows attackers to execute scripts via unsanitized URL parameters.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"extra_packages_for_enterprise_linux","vendor":"fedoraproject"},{"product":"fedora","vendor":"fedoraproject"},{"product":"moodle","vendor":"moodle"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in moodle","id":"CVE-2021-43558","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:extra_packages_for_enterprise_linux","products":["fedoraproject:extra_packages_for_enterprise_linux","fedoraproject:fedora","moodle:moodle"],"type":"xss","year":"2021"},"n_packages":7,"n_references":2,"next":{"headline":"Moodle contains CSRF vulnerability","id":"CVE-2021-43559"},"packages":[{"ecosystem":"Bitnami","fixed":["3.8.9","3.9.11","3.10.8","3.11.4"],"introduced":["0","3.9.0","3.10.0","3.11.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2021-43558"},{"ecosystem":"Packagist","fixed":["3.10.8"],"introduced":["3.10.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-wpfp-q843-v772"},{"ecosystem":"Packagist","fixed":["3.10.8"],"introduced":["3.10.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-wpfp-q843-v772"},{"ecosystem":"Packagist","fixed":["3.11.4"],"introduced":["3.11.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-wpfp-q843-v772"},{"ecosystem":"Packagist","fixed":["3.11.4"],"introduced":["3.11.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-wpfp-q843-v772"},{"ecosystem":"Packagist","fixed":["3.9.11"],"introduced":["3.9.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-wpfp-q843-v772"},{"ecosystem":"Packagist","fixed":["3.9.11"],"introduced":["3.9.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-wpfp-q843-v772"}],"prev":{"headline":"Path traversal in request_uri variable","id":"CVE-2021-43557"},"products":["moodle"],"published":"2021-11-22","related":[{"cvss_score":9.8,"headline":"Command injection in ImageMagick","id":"CVE-2023-34152","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"Code injection in rxvt-unicode","id":"CVE-2022-4170","kev_date_added":null,"published":"2022-12-09"},{"cvss_score":9.8,"headline":"Moodle Minor SQL injection risk in admin user browsing","id":"CVE-2022-40315","kev_date_added":null,"published":"2022-09-30"},{"cvss_score":9.1,"headline":"Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library","id":"CVE-2022-45152","kev_date_added":null,"published":"2022-11-25"},{"cvss_score":9.1,"headline":"Server side NTLM does not properly check parameters in FreeRDP","id":"CVE-2022-24882","kev_date_added":null,"published":"2022-04-26"},{"cvss_score":8.8,"headline":"Use after free in Chrome","id":"CVE-2022-2158","kev_date_added":null,"published":"2022-07-28"},{"cvss_score":8.8,"headline":"Use after free in Chrome","id":"CVE-2022-2163","kev_date_added":null,"published":"2022-07-28"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Reflected XSS in Moodle's site administrator tool allows attackers to execute scripts via unsanitized URL parameters.","url":"https://insights.sbomify.com/CVE-2021-43558/"}