CVE-2021-43559 Moodle contains CSRF vulnerability
Attackers can force authenticated users to delete related badges via CSRF due to missing token checks in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-43559?
CVE-2021-43559 is a high-severity vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. The "delete related badge" functionality did not include the necessary token check to prevent a CSRF risk.
Weakness: CWE-352
Which versions are affected by CVE-2021-43559?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.8 |
moodle/moodle Packagist | From 3.10 | 3.10.8 |
moodle/moodle Packagist | From 3.11 | 3.11.4 |
moodle/moodle Packagist | From 3.11 | 3.11.4 |
moodle/moodle Packagist | From 3.9 | 3.9.11 |
moodle/moodle Packagist | From 3.9 | 3.9.11 |
1 more packages
moodle Bitnami | All versions | 3.8.9, 3.9.11, 3.10.8, 3.11.4 |
Products include Fedoraproject Extra Packages for Enterprise Linux, Fedoraproject Fedora, Moodle Moodle.
How do I fix CVE-2021-43559?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.8, 3.11.4 or 3.9.11.
Is CVE-2021-43559 being exploited?
There is no known exploitation of CVE-2021-43559 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Extra Packages for Enterprise Linux
- CVE-2023-34152 Command injection in ImageMagick
- CVE-2022-4170 Code injection in rxvt-unicode
- CVE-2022-40315 Moodle Minor SQL injection risk in admin user browsing
- CVE-2022-45152 Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library
- CVE-2022-24882 Server side NTLM does not properly check parameters in FreeRDP
All Fedoraproject Extra Packages for Enterprise Linux vulnerabilities
Sources
Also known as BIT-moodle-2021-43559, GHSA-3jrj-x6cj-97cp, UBUNTU-CVE-2021-43559.