CVE-2021-43560 Moodle Insecure direct object reference (IDOR) in a calendar web service
Attackers can view other users' calendar action events due to insufficient capability checks in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-43560?
CVE-2021-43560 is a medium-severity missing authorization vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. Insufficient capability checks made it possible to fetch other users' calendar action events.
Which versions are affected by CVE-2021-43560?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.10 | 3.10.8 |
moodle/moodle Packagist | From 3.10 | 3.10.8 |
moodle/moodle Packagist | From 3.11 | 3.11.4 |
moodle/moodle Packagist | From 3.11 | 3.11.4 |
moodle/moodle Packagist | From 3.9 | 3.9.11 |
moodle/moodle Packagist | From 3.9 | 3.9.11 |
1 more packages
moodle Bitnami | All versions | 3.8.9, 3.9.11, 3.10.8, 3.11.4 |
Products include Fedoraproject Extra Packages for Enterprise Linux, Fedoraproject Fedora, Moodle Moodle.
How do I fix CVE-2021-43560?
Upgrade moodle/moodle to a fixed version for your release line: 3.10.8, 3.11.4 or 3.9.11.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-43560 being exploited?
There is no known exploitation of CVE-2021-43560 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Extra Packages for Enterprise Linux
- CVE-2023-34152 Command injection in ImageMagick
- CVE-2022-4170 Code injection in rxvt-unicode
- CVE-2022-40315 Moodle Minor SQL injection risk in admin user browsing
- CVE-2022-45152 Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library
- CVE-2022-24882 Server side NTLM does not properly check parameters in FreeRDP
All Fedoraproject Extra Packages for Enterprise Linux vulnerabilities
Sources
Also known as BIT-moodle-2021-43560, GHSA-g39c-mccf-rxjv, UBUNTU-CVE-2021-43560.