# CVE-2021-43560: Moodle Insecure direct object reference (IDOR) in a calendar web service

> Attackers can view other users' calendar action events due to insufficient capability checks in Moodle.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-moodle-2021-43560, GHSA-g39c-mccf-rxjv, UBUNTU-CVE-2021-43560

## What is CVE-2021-43560?

CVE-2021-43560 is a medium-severity missing authorization vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. Insufficient capability checks made it possible to fetch other users' calendar action events.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-43560?

7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.10 | 3.10.8 |
| `moodle/moodle` | Packagist | From 3.10 | 3.10.8 |
| `moodle/moodle` | Packagist | From 3.11 | 3.11.4 |
| `moodle/moodle` | Packagist | From 3.11 | 3.11.4 |
| `moodle/moodle` | Packagist | From 3.9 | 3.9.11 |
| `moodle/moodle` | Packagist | From 3.9 | 3.9.11 |
| `moodle` | Bitnami | All versions | 3.8.9, 3.9.11, 3.10.8, 3.11.4 |

Products: Fedoraproject Extra Packages for Enterprise Linux, Fedoraproject Fedora, Moodle Moodle.

## How do I fix CVE-2021-43560?

Upgrade moodle/moodle to a fixed version for your release line: 3.10.8, 3.11.4 or 3.9.11.

## Is CVE-2021-43560 being exploited?

There is no known exploitation of CVE-2021-43560 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Extra Packages for Enterprise Linux

- [CVE-2023-34152](https://insights.sbomify.com/CVE-2023-34152/): Command injection in ImageMagick (critical 9.8)
- [CVE-2022-4170](https://insights.sbomify.com/CVE-2022-4170/): Code injection in rxvt-unicode (critical 9.8)
- [CVE-2022-40315](https://insights.sbomify.com/CVE-2022-40315/): Moodle Minor SQL injection risk in admin user browsing (critical 9.8)
- [CVE-2022-45152](https://insights.sbomify.com/CVE-2022-45152/): Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library (critical 9.1)
- [CVE-2022-24882](https://insights.sbomify.com/CVE-2022-24882/): Server side NTLM does not properly check parameters in FreeRDP (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43560 and fix it if it is affected.

What it is: CVE-2021-43560 is a medium-severity missing authorization vulnerability in Fedoraproject Extra Packages for Enterprise Linux, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43560 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.8
- moodle/moodle (Packagist): affected from 3.10; fixed in 3.10.8
- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.4
- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.4
- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.11
- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.11
- moodle (Bitnami): affected all versions; fixed in 3.8.9, 3.9.11, 3.10.8, 3.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43560/ (Markdown: https://insights.sbomify.com/CVE-2021-43560/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43560
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43560
- OSV: https://osv.dev/vulnerability/CVE-2021-43560

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43560/
Summaries are generated and may contain mistakes; the official description above is the record.
